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Winlink Overview

Airmail Installation

Airmail Configuration for Telnet  (over internet)

Airmail Configuration for Packet  (over V/UHF radio)

Telpac Demonstration
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What is Winlink?

A Worldwide radio messaging system that takes advantage of the 
Internet where possible 

Utilizes standard RFC2821 e-mail protocols allowing flexibility with 
the most commonly used communications tool

Ability to send file attachments

System is a ‘star’ based network containing 4 mirror imaged, fully 
redundant Common Message Servers (CMS)

Radio Message Servers (RMS) connect like the end of spokes on 
a wheel
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Why use Winlink?

Email messaging is common to most everyone (universal)

Minimal training since message composition is just like Email

Winlink’s Suite of FREE applications provide flexible connection options

Messages are easily archived with date/time stamp

Compression of messages is more efficient for limited bandwidth

Let’s see how it all fits together………..
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Applications:

Airmail Client

Telnet  ( internet connection )

Packet  (VHF/UHF Radio connection )

Pactor  (HF Radio connection )

RMS Packet (Telpac) Gateway

Packet to Telnet bridge

RMS Pactor

Pactor to Telnet bridge

RMS Relay (still in development)

Holds messages if Internet is down

Bridges Packet to Pactor if needed
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Applications:

Paclink MP

POP/SMTP Server on LAN

Outlook, Thunderbird, WebMail

Tactical e-mail addressing

Telnet, Packet, Pactor connectivity

Channelized, can set path priority

AGWPE

Outpost

APRSLink
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History:

• Winlink Development Team started this system in the early 80’s

• Victor Poor wrote an Amtor to Packet link - DOS application, Aplink

• Navy MARS users used a smaller client version of Aplink called PAMS

• Aplink gained recognition in the Gulf War in 1990 (CBS Documentary)

• Winlink Classic when Windows was available (text only)

• Netlink interfaced radio digital messaging to the Inernet

• Winlink/Netlink evolved into Airmail (written by Jim Corenman KE6RK)

• 1998 Winlink 2000 planning started and was working by Feb 1999

• Provides critical wx reports and forecasts to mariners and isolated users

• Built with complete redundancy to be used for Emergency Comms

• 150,000 messages monthly

• Over 5100 users via RF 
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Download from http://www.siriuscyber.net/ham/

Run Setup:

http://www.siriuscyber.net/ham/
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Accept all defaults:
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First time you start the 
program, Setup Wizard 
runs

Enter your Callsign:

Runtime Setup Wizard
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Runtime Setup Wizard

Location info is optional

Select defaults if not setting up 
for HF
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Runtime Setup Wizard

Select No for radio remote 
control (unless you’re using it)

Click on Finish, basic setup is 
done
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You are first greeted with 
the Inbox
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Additional Options can be 
selected through the Tools 
Menu
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Compose Message

To Compose your message, 
click on File > New, or click on 
the new message icon
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Compose Message

Address Book pops up, you can 
cancel  to go straight to your 
message window or enter new 
addresses
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Compose Message

Enter your destination addresses. If going to Winlink account, 
only put the callsign. Separate multiple addresses with a 
comma. Enter your subject and type your message.
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Compose Message

Post Via is for routing. If routing message through internet, use WL2K.   
If sending message peer to peer, enter callsign of station you will 
connect to. ( more peer to peer on later slide )



Using Winlink 2000Using Winlink 2000AirmailAirmail

Post Routing

In its simplest form the Message-Routing list is used for posting messages created within Airmail. There are typically two 
entries: One that says what to do with email created by the user, and another that says what to do otherwise (i.e. not email, 
for example a message to another ham callsign. 
For Winlink users these entries will be:

user -- email -- WL2K
user -- default -- WL2K

This means messages created by the user and which are addressed to an email address will be posted "via" WL2K, and 
anything else is also posteed "via" WL2K. Note that the "default" entry is last, this is important- otherwise the "default" would 
match everything, and the "email" entry would never be used. Note that "WL2K" is a special system name, and matches any 
ham-station that identifies itself as "WL2K" in the system-id codes, via HF, packet or telnet. 

AirMail Help ©1997-2006 Jim Corenman
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Click on Mailbox Icon to 
post for sending
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Message is posted in Outbox (notice Icon)
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Sending Via Telnet ( Internet )

Click Modules, Internet Access 
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Sending Via Telnet          Click on Settings

Use these settings for Telnet 
route ( your callsign should 
be displayed )
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Telnet Status

Watch the status of 
the connection to see 
how things are. 

Look for errors and 
debug info if there is 
a problem.
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Message Sent

Once message is sent, the icon changes to green checkmark.
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Attach File to message

You can send small attachments 
( < 100kB )

Click on File > Attach File…
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Attach File to message     

Browse to the file you want. ( .exe and .zipfiles will not go through the system )
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Attach File to message

File attached, ready to send. Remember to check your Post Via, then click on 
Mailbox Icon to post.
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Packet Client Setup

To set up Airmail for RF Packet, click on Tools > Options…
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Packet Client Setup

Then click on Modules tab, select VHF Packet checkbox, then click Setup.

Here’s where you select your TNC 
and COM port settings.
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Send Via Packet

To send via RF Packet, click Modules > Packet Client.

AirmailAirmail
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Send Via Packet          Looks like the Telnet window. 

Enter the RMS/Telpac node callsign where you wish to connect in the 
Connect to: box…. A digi can be added in the path by leaving a single space 
between the RMS callsign and the digi callsign. 

Ex. Connect to: | KG4VUBKG4VUB--10 N3DAB10 N3DAB--7  7  |

Aliases cannot be used for digi, must be the callsign for the digi.

AirmailAirmail
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Send Via Packet

Make sure “Packet 
initialized OK” is 
displayed to ensure 
communication with 
the TNC is good.

Click on the green 
button to initialize the 
RF connection.

AirmailAirmail
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Packet Connect Status

Watch the status text 
and make sure there are 
no errors.

The status bar near the 
bottom indicates 
progress of message 
transfer.

AirmailAirmail
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Packet Connect Status

On successful delivery, 
you will see the F6FBB 
commands FF FQ.

Make sure the link 
disconnects.

AirmailAirmail
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Messages sent ( notice the Icon changes to green checkmark )
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Peer to Peer Connections

The receiving station should make sure that its “Tools…Options….AutoAnswer”
box is checked for “Accept Incoming Connects”.

Both stations should be using the Handshake mode.

The message should be Posted to the Receiving station. 



Using Winlink 2000Using Winlink 2000AirmailAirmail

Options Message

To change system settings, such as max file attachment size and Whitelist

Click on Window > Winlink-2000 > Options Message
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Options Message

Here, turn Whitelist On or Off, Attachment limit for RF, and you can also tell 
the system to forward your <callsign>@winlink.org email messages to 
another ‘Alternate’ address.
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Options Messages can be sent as a message. 

You can turn Whitelist On or Off. If turned On, you can specify email 
addresses and domains to allow incoming messages.

Attachment size and other options can also be done this way.
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After entering your Options, post the message for sending and connect to the 
WL2K system.

To check your options, you can send a INQUIRY message and receive the 
info the next time you connect.
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Dumb Terminal

Dumb Terminal mode can be used to change TNC settings. Make sure the 
Packet Client Module is closed before running Dumb Terminal. 
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Dumb Terminal

Set the COM port and speed, then click in the main body of window. You 
might need to uncheck Local Echo if you start seeing double.
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Catalogs       - Airmail and Winlink support catalog file downloads. Click on 
Window Catalogs and browse around. Select one and next time you connect, the 
request will be sent. Connect again and you should receive your info.
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Catalogs

Notice Icon changed for posting, request is ready to be sent.
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Catalogs

Again, watch the 
status of the 
connection and 
download.
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---- Q8510 How do I access the Winlink system, using Keyboard Access?

A8510 Connect to a Telpac or RMS Packet Gateway Station.

LM List all messages for me.
RM Read all messages for me.
KM Kill (delete) all messages for me.
R xx Read content of message number xx.
K xx Kill message number xx.
SP Send a message (see A8520)
H Help File
Bye Disconnect
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- New e-mail addresses are automatically added to your Whitelist when the CMS receives the message from you, independent 
of which user program you are using.
- Whitelist settings

To: System
Subject: Whitelist
LIST will return a list of all Whitelist and Blacklist entries for the user.

ACCEPT: jblow@somewhere.com will allow messages from jblow@somewhere.com to be accepted. You may send multiple 
lines, each containing one e-mail address.

Reject: jblow@somewhere.com will reject any messages from jblow@somewhere.com. You may send multiple lines, each 
containing one e-mail address.

Delete: jblow@somewhere.com will remove jblow@somewhere.com from the user's Whitelist. You may send multiple lines, each 
containing one e-mail address.

ACCEPT: arrl.net will allow all messages from xxxxxx@arrl.net to be accepted

REJECT: Verizon.com will reject all messages from xxxxxx@verizon.com

IMPORTANT NOTE: Domain Entries without the "@" will be treated as "domain names" only. For example if "Accept: 
sailmail.com" were entered, then ANY message from that "domain name" (sailmail.com) would be accepted.

- Q630 How does the Winlink system deal with Spam?

A630 Messages incoming to WL2K users are filtered, using high level methods, by the Central Message Server (CMS). Winlink 
2000 uses the information from SPAMCOP. It also requires a reverse DNS lookup. Each server IP address must return a PTR- 
record that matches the HELO or ELHO command received from that server and it must have an A-record that matches the host 
name shown in the HELO or ELHO command. If such a record exists, then it has entry to the Whitelist system.

In addition, individual WL2K users have the ability to use a “Whitelist”. “Whitelist” is the default method for new users. Your 
choice may be changed at any time. If you decide to not use your Whitelist, you will get a lot of Spam. It is recommended that all 
users turn their Whitelist “ON”.

As of September 2007 WL2K is no longer using a Spam Filter with a “Threshold”. Ignore references to a Spam Threshold in the 
AirMail software.
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There's certainly been a lot of discussion about Windows Vista. If your new computer came with Vista then that's great, it works fine. 
But if you have the option of using Windows-XP then that would be our recommendation. Win-XP is robust and reliable, if yours is not 
then something has been compromised and you need to fix it or start over-- upgrading won't help. 

Airmail runs fine under Windows Vista, but there are a couple of issues related to new Vista security features-- the "release notes" 
message keeps re-appearing on each restart, as does a "pop-up" box that the configuration has been updated. The simplest fix is to 
delete the release notes ("amupdate.msg" from Airmail's Import folder, under Program Files) and the "system.sailmail.txt" text-file in 
the Airmail folder. Also Right-click Airmail's desktop icon and select "properties", click on "compatibility" tab and then check the "Run 
in compatibility mode" box and select "Windows-XP", this will enable Airmail's COM-port identification. 

Alternately you can run Airmail as an administrator, that will allow Airmail full access to its own files. (By default Vista "demotes" 
administrators to normal users). Right-click Airmail's desktop icon and select "properties", click on "compatibility" tab and then check 
two boxes: run in compatibility mode for Windows-XP, and run as administrator. This will allow Airmail to have full access to its own 
folders and delete the release-notes and configuration files. 

The third option is to turn off UAC (see below). This has the same effect as running Airmail as an administrator, but also extends 
admin privileges to all other programs (including malicious code if you are not careful about computer security). 

The culprit with all this is a new security feature in Win-Vista called "UAC" (User Account Control). (Remember, if you can do 
anything useful with your computer then it is not sufficiently secure). UAC is a watchdog service that warns you if you (or a program) 
are trying to do something that requires administrator privileges, e.g. delete protected files or run a program not specifically designed 
for Vista. And, if a program attempts to write into protected areas (e.g. the "program files" folder), then access is diverted to a virtual 
folder created for that user. The result, for Airmail, is a mild case of schizophrenia, and release-notes that just keep reappearing 
because the file (in Airmail's Program Files/Import folder) can't be deleted. 

Running Airmail in administrative mode (by checking the "run as administrator" box, above) allows Airmail to fully access its own files 
and resolves that problem. Also, turning off UAC will accomplish the same thing. To turn off UAC go to Windows Control panel, open 
"User Accounts" and find "User Account Control". 

Running Airmail under Windows Vista
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There is one wrinkle with changing the run-as-administrator setting and/or turning off UAC after Airmail has been run: Your 
messages and settings may disappear. This is because Vista was previously diverting Airmail's files to a "virtual" folder, and 
with UAC off (or run-as-administrator selected) it will stop doing this. The fix is to move your messages back to the "proper" 
folder: Close Airmail, open Windows Explorer (under "Accessories" in the Windows start menu), find "Computer", then C- 
drive, Users, your user-name, AppData, Local, VirtualStore, then "Program Files" and finally "Airmail". In that folder you will 
find all of your message-folders and settings files-- move the whole lot to the Airmail folder that is under Program Files. If the 
UAC/admin settings change again then Vista will start diverting Airmail's files again-- but you now know where to go and 
fetch them back. 

Note: Windows does not like to show the contents of system folders: Open Windows-Explorer's "Tools" menu, "Folder 
Options". Click the "View" tab, and check "Show hidden files and folders", NO check for "Hide file extensions for known file 
types", NO check for "Hide protected operating system files" (and click "Yes" to the confirmation). This will show all files, 
and also show file-extensions. 

Running Airmail as administrator will show a warning box each time it is run, and turning off UAC will show a warning with 
each reboot, those are unavoidable. And of course if you turn off UAC be doubly-careful to keep your anti-virus software up- 
to-date. 

Help file: Vista does not include the program to display the traditional help files, "Winhlp32.exe". This may be available for 
download, alternately it can be copied from Windows-XP C:\Windows folder. To do this you will first need to set the 
permissions for the C:\Windows folder to allow Administrators full access, and to do this you will need to first take ownership 
(right-click the Windows folder, select properties, then Security tab, Advanced button, Owner tab, Edit button). Then copy 
the complete (277KB) Winhlp32.exe from Win-XP over the 9KB "stub" Winhlp32.exe on Win-Vista. 

The upcoming Airmail 3.4 update will fix all this, moving message-folders into Win-Vista's "ProgramData" user-space and 
gathering up any virtual-folders that were created. The help file will also be converted to HTML format. The goal is for 
Airmail to run smoothly under Vista's highest security settings but this will take some effort. 

--Jim (revised Mar 5 2008)

Running Airmail under Windows Vista  -Continued
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Tune in later for details on RMS Packet installation and use.

Upcoming presentations on Paclink MP installation and 
configuration and use.
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Winlink 2K for Dummies
http://www.winlink.org/node/23
http://groups.yahoo.com/group/LOADING_WL2K_USER_PROGRAMS/

A Winlink Help Page
http://www.activeham.com/winlink/wiki/index.php?title=Main_Page

Airmail download
http://www.siriuscyber.net/ham/

Airmail Support
http://groups.yahoo.com/group/airmail2000/

Running Airmail on Vista
http://saildocs.com/vista

Rules of Engagement for Winlink 2000
http://www.winlink.org/node/16
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CMS Status
http://www.winlink.org/CMSStatus

Telpac/RMS Status
http://www.winlink.org/RMSpacketStatus

Telpac/RMS Position Maps
http://www.winlink.org/RMSPacketPositions

RMS Packet (Telpac replacement still in Beta)
http://groups.yahoo.com/group/RMSBeta/

Paclink MP
http://groups.yahoo.com/group/PaclinkMP
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Winlink 2000 Roadmap
http://www.winlink.org/node/19

Winlink use in EmComm
http://groups.yahoo.com/group/wl2kemcomm/

F6FBB protocol
http://www.f6fbb.org/protocole.html

F6FBB B2 
http://www.winlink.org/B2F

Linux version of Telpac
http://www.prgm.org/projekte/telpac-node/
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